MindView Advanced Training Guide (PC)

How can MindView be used as a Study Skill tool by students?

MindView is a mind mapping solution which can genuinely help students with their studies.
Students using MindView are able to:

e Quickly generate and review ideas visually

e Plan, outline and structure both assignments and dissertations, research and
presentations

e Include references directly in the mind map thanks to the integration with WorldCat
(Online Bibliographic Database with over 1.6 Billion Sources)

e Organise revision, lecture notes and research visually

e Manage time effectively by creating timelines and visual action plans or using the
Project Management Features

Building a mind map in MindView

Whether it is creating a simple mind map for revision, a Word document with an interactive
contents page for a dissertation or a timeline for an action plan, MindView offers a quick
and easy solution for all students.

Building mind map and inserting content

Mind maps can be quickly built by adding branches using Enter for Main branches and
Insert for sub-branches. Content can be added in the form of text notes, attachments,
hyperlinks and images.

Exporting the mind map

MindView exports to a wide variety of external formats including Microsoft Word,
PowerPoint, Outlook, Excel, Project as well as HTML and PDF. Clicking on Advanced




export gives maximum control and allows students to control how they want their exported
document to appear.

Timelines

The timeline view in MindView allows students to create visual action plans or historic
timelines. If students wish to make a straightforward timeline they must ensure that they go
to the task timeline tab on the right and change the document type to timeline.

Study Skills Templates

A number of study skills templates are now included in MindView. These templates are
designed to show students that mind mapping can be used as more than just a planning
tool. MindView is used effectively as a study strategy tool for a wide range of difficulties
faced by all students.

Planning Work — Assignments, Dissertations and Presentations

When initially faced with an Assignment Title students might wish to get ideas down as
quickly as possible in a random order. They can either add branches to their mind map or
by double clicking outside the map to add unconnected ideas which can later be dragged
onto the mind map.

Adding in the numbering scheme allows students to re-order their mind maps visually by
simply dragging and dropping branches into place. Students can then review their
documents by switching to the Outline view and do a Word Count or read parts of the map
back to them. Finally they can export to Microsoft Word for written work, or to PowerPoint
for presentations and further editing can be done directly in these programmes.

Exporting the Study Skills template Famous Authors shows how these Word Documents
and PowerPoint presentations will look.
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Organisation — Lecture Notes, Revision and Research

MindView can be used as a tool to help with organisation as students can create mind
maps for visual file organisation — no more need to search for those important files in
folders on the desk top! Using the Focus Mode with F6 allows students to concentrate on
branches or groups when revising or doing targeted research.

The Study Skills template Organisation of Lecture Notes shows an Academic Module
broken down into chunks of Lectures and has some branches representing the key
learning objectives. All relevant notes, files and hyperlinks related to the Lecture can then
be included on the Lecture Branch.
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Time Management

The unique Timeline view in MindView offers students with time management difficulties
the ability to break up a project into chunks, thus making it seem more manageable.
Whether it be planning a dissertation or essay, putting together a revision plan or getting
an overview of the whole Semester, the Timeline View allows students to plan and
manage their time effectively.

The study skills template Essay Plan — Time Schedule shows the steps involved in writing
some Academic Work. Click on the View tab and then Timeline and the map switches into
a Visual Action Plan which can be printed off or saved on the Computer.
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Furthermore, students are able to use the project management features within MindView
to track how they are progressing with work by monitoring the percentage completion of
each task and also the project as a whole.

The study skills template, Research Completion shows how Scientific Research can be
broken up in a mind map and the percentage completion can be changed using the
task/timeline tab on the right hand side. This also breaks up complicated projects into
smaller sub-projects using branches and sub-branches.
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Personalising your mind map and adding a Legend

The Design tab allows students to choose from a range of layouts and styles. Students are
also able to add colours to individual branches using the format tab once a branch is
highlighted. Students can choose to add a boundary onto a group of branches to break
down the map into chunks or they can add a fill colour onto branches. Any colours added
to branches will also appear on the timeline allowing students to break up both mind maps
and action plans with one click.

Additionally, students can add a Legend onto their mind map which allows them to label
the different colours in a panel on their maps.
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Restructuring and Reviewing the mind map

MindView allows students to review their work directly in the mind map without the need to
use other programmes for structuring, text to speech or word counts.

Numbering Scheme

MindView allows ideas to be quickly re-arranged visually by dragging branches into new
positions. To see the order that these branches will be exported in, click on the Numbering
Scheme. This unique feature will help students to effortlessly visualise a breakdown of the
structure of their assignments. Branches which are moved in one view will be updated in
all the different views, including the outline view.

Narration Function and Document Statistics

Students can have branches or text notes read back to them by going to the Review tab
and clicking on the Narrate tab. They can also click F5 to start and stop the narration.

Students are able to do an instant Word Count by clicking on the Document Statistics
Button in the Review Tab. This will give you a Word Count of Individual branches
(including all text notes) as well as the whole document.

Simple interface

The Academic version of MindView now opens up with the Simple interface as standard.
To access the full range of features available in MindView go to the View tab and click on
the Simple Interface button.
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Bibliography

MindView integrates with an online bibliographic tool called WorldCat. WorldCat has over

1.6 billion sources and students are able to search on ISBN number, Author and Title.

Managing Sources

When the text note editor is open clicking on Citation brings up a drop down menu. Click
on Manage Sources and assuming students are online they are able to search WorldCat

for sources including books, films and journals. WorldCat generates all the information for

referencing including Year of publishing, Publisher, City of Publishing etc.

Source Results | Manual Entry Mode |

jiames joyce All Types v] [AJI Languages V] [ Search ]
Showing results -9 - 1 of 21201 Lf,\ Powered by WorddCat®
A portrait of the artist as a young man., 1964 =
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Book 7
Ulysses., 1946
Book 3
Dubliners,, by James Joyce; introduction by Padraic Colum., 1926
-y Select
Book 7
Finnegans wake, [by] James Joyce., 1939 N
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Book 7
The portable James Joyce, with an introduction & notes by Harry
| | Levin., 1947 Salact
Book %
The essential James Joyce, with an introduction and notes by Harry
| | Levin., 1948 Salact L

If a student is not online or the source is not in WorldCat then thry are also able to

manually add all the information too.




Adding a citation

When a student requires a citation they click on the Citation button and then Insert
Citation. From here they are able to choose the source the citation is from and add in a
page number if required. This citation will appear in the desired referencing style in the
Microsoft Word document.

Creating a Bibliography in Microsoft Word

When exporting to Microsoft Word ensure that students choose Advanced Word Export.
Choose one of the Referencing templates (Harvard, APA, MLA) and then under the
General tab select Include Bibliography and it will appear at the end of the document in the
required style.
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Integration with Microsoft Outlook

Dates from a timeline or Gantt chart can be exported to Outlook. These dates will appear
in the task list in Outlook and these can be dragged into the Outlook calendar if required.
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GanttChart

MindView allows students to build Project Management Gantt charts. A Gantt Chart is a
visual chart which illustrates a project schedule. Gantt charts include the start and finish
dates of task and summary elements of a project.
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Students can start planning their projects as a mind map and can then restructure the
order in one of the different map views — the top down view is very popular.

Project Management

Before switching to the Gantt view, go to the Task/Timeline Tab on the right hand side and
ensure the document type is Project Management. This panel also shows the different
time and task information that can be included within the Gantt Chart.
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Time and task Information

Students are able to add in the duration of tasks and also specific start dates (if required).
They can add task priorities, percentage completion and resources. Resources are
members of the team and these can include email addresses. When exporting to Outlook
these tasks will be allocated to the different team members.

Linking tasks together - Dependencies

Once in the Gantt view tasks can be linked together by dragging out a dependency. Click
and hold on the first task you wish to link and drag a line to the second task to which it is
linking. The standard dependency is "As soon as possible” meaning as soon as one task
is finished the next one can start. Students can also choose to have tasks running
simultaneously or starting/ending on specific dates.

Project Management reports

Students can view their Gantt charts in a different view by using the Project Reports.
Students are able to get graphical overviews of their projects, view different task statuses
and resource allocations.




Summary Tasks Sub-Tasks M Unstarted in Progress [l Completed
Organizing an Event 48
2 1 Planning 8 8
11 2 Arrange venue 3 2 [
16 3 Invitations 9 [ |
28 4 Travel and accommuodation 3 ]
32 5 Support materials 4 .
37 6 Faciliies 12 I
52 7 Final run-up 9 [ ]
Total Tasks 48 s s

Summary Tasks

Summary Tasks Sub-Tasks Completion Status and Number of Workings Days Needed M completed  [] Remaining
Organizing an Event 43
2 1Planning g PEe 100%
11 2 Arrange venue 3 E e
16 3 Invitations 9 I 3z ] 17%
28 4 Travel and accommodation 3 0%
32 5 Support materials 4 [ 186 | 0%
a7 G Facilities 12 0%
52 7 Final run-up ] 0%

Total Tasks 48

Applying a filter to the mind map

With larger mind maps students may wish to filter branches. The Filter can be found in the
view tab. To add a filter click on Filter and then go to new. Filters can be added on
resource, icons, start date and end dates etc.

Adding Calculations to the Mind Map

Calculations can be added to the mind map to make a “Visual Spreadsheet”. Opening up
the Calculation tab on the right hand side allows students to add in names and values and
do a number of different calculations on the mind map. These can then be exported to
Microsoft Excel.
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